路由器的配置:
router>
用戶模式
1
:進入特權模式 enable
router > enable
router #
2
:進入全局配置模式 configure terminal
router > enable
router #configure terminal
router (conf)#
3
:交換機命名 hostname routera routerA為例
router > enable
router #configure terminal
router(conf)#hostname routerA
routera (conf)#
4
:配置使能口令 enable password cisco cisco為例
router > enable
router #configure terminal
router(conf)#hostname routerA
routerA (conf)# enable password cisco
5
:配置使能密碼 enable secret ciscolab cicsolab為例
router > enable
router #configure terminal
router(conf)#hostname routerA
routerA (conf)# enable secret ciscolab
6
:進入路由器某一埠 interface fastehernet 0/17 17埠為例
router > enable
router #configure terminal
router(conf)#hostname routerA
routerA (conf)# interface fastehernet 0/17
routerA (conf-if)#
進入路由器的某一子埠 interface fastethernet 0/17.1 17埠的1子埠為例
router > enable
router #configure terminal
router(conf)#hostname routerA
routerA (conf)# interface fastehernet 0/17.1
7
:設置埠ip位址資訊
router > enable
router #configure terminal
router(conf)#hostname routerA
routerA(conf)# interface fastehernet 0/17
17埠為例
routerA (conf-if)#ip address 192.168.1.1 255.255.255.0
配置交換機埠ip和子網路遮罩
routerA (conf-if)#no shut
是配置處於運行中
routerA (conf-if)#exit
8
:查看命令 show
router > enable
router # show version
察看系統中的所有版本資訊
show interface vlan 1
查看交換機有關ip 協定的配置資訊
show running-configure
查看交換機當前起作用的配置資訊
show interface fastethernet 0/1
察看交換機1介面具體配置和統計資訊
show mac-address-table
查看mac地址表
show mac-address-table aging-time
查看mac位址表自動老化時間
show controllers serial +
編號 查看串口類型
show ip router
查看路由器的路由表
9
cdp相關命令
router > enable
router # show cdp
查看設備的cdp全局配置資訊
show cdp interface fastethernet 0/17
查看17埠的cdp配置資訊
show cdp traffic
查看有關cdp包的統計資訊
show cdp nerghbors
列出與設備相連的cisco設備
10
csico2600的密碼恢復
重新啟動路由器,在啟動過程中按下win+break鍵,使路由器進入rom monitor
在提示符下輸入命令修改配置寄存器的值,然後重新啟動路由器
remmon1>confreg 0x2142
remmon2>reset
重新啟動路由器後進入setup模式,選擇“no”,退回到exec模式,此時路由器原有的配置仍然保存在startup-config中,為使路由器恢 復密碼後配置不變把startup-config中配置保存到running-config中,然後重新設置enable密碼,並把配置寄存器改回 0x2102
router>enable
router#copy startup-config running-config
router#configure terminal
router(conf)#enable password cisco
router(conf)#c onfig-register 0x2102
保存當前配置到startup-config , 重新啟動路由器。
router #copy running-config startup-config
router #reload
11
:路由器telnet遠端登錄設置:
router>en
router #configure terminal
router (conf)#hostname routerA
routerA (conf)#enable password cisco
cisco為特權模式密碼
routerA (conf)#interface fastethernet 0/1
17埠為telnet遠端登錄埠
routerA (conf-if)#ip address 192.168.1.1 255.255.255.0
routerA (conf-if)#no shut
routerA (conf-if)#exit
routerA (conf)line vty 0 4
設置0-4 個用戶可以telnet遠端登陸
routerA (conf-line)#login
routerA (conf-line)#password edge
edge為遠端登錄的用戶密碼
主機設置:
ip 192.168.1.2
主機的ip必須和交換機埠的位址在同一網路段
netmask 255.255.255.0
gate-way 192.168.1.1
閘道位址是交換機埠位址
運行:
telnet 192.168.1.1
進入telnet遠端登錄介面
password : edge
routera>en
password: cisco
routera#
12
:配置路由器的標識 banner $……………$
在全局配置的模式下利用“banner”命令可以配置路由器的提示資訊,所有連接到路由器的終端都會收到。
router>en
router #c onfigure terminal
router (conf)#hostname routerA
routerA(conf)#banner motd $This is aptech company’ router ! Please don’t change the configuration without permission!$
13
:配置介面標識 description ………
介面標識用於區分路由器的各個介面。
router>en
router #c onfigure terminal
router (conf)#hostname routerA
routerA(conf)#interface fastethernet 0/1
0/1 介面為例
routerA(conf-if)# description this is a fast Ethernet port used to connecting the company’s intranet!
14
:配置超時
超時適用於設置在多長時間沒有對console進行配置,自動返回exec會話時間。默認為10分鐘。
router>en
router #c onfigure terminal
router (conf)#hostname routerA
routerA(conf)#line console 0
routerA(conf-if)#e xec-timeout 0 0
第一個0”代表分鐘,第二個0”代表秒
15
:配置串口參數
兩台路由器通過串口連接需要一個做為DTE,一個做為DCEDCE設備要向DTE設備提供時鐘頻率和帶寬。
DCE
配置:
router>en
router #c onfigure terminal
router (conf)#hostname routerA
routerA(conf)#interface serial 0/0
routerA(conf_if)#clock rate 64000
提供時鐘頻率為64000
routerA(conf_if)#bandwidth 64
提供帶寬為64
DTE
配置:路由器串口配置ip位元元址
router>en
router #c onfigure terminal
router (conf)#hostname routerB
routerB(conf)#interface serial 0/0
routerB(conf_if)#ip address 192.168.1.1 255.255.255.0
16
:靜態路由的配置
配置路由器A的主機名和介面參數
router>enable
router#c onfigure terminal
router(conf)#hostname routerA
routerA(conf)#interface fastethernet 0/1
路由器A1埠為兩路由器的連接埠
routerA(conf-if)#ip address 192.168.2.1 255.255.255.0
routerA(conf-if)#no shutdown
routerA(conf-if)#exit
routerA(conf)# interface fastethernet 0/0
路由器A0埠為與主機的連接埠
routerA(conf-if)#ip address 192.168.1.2 255.255.255.0
routerA(conf-if)#no shutdown
主機Aip位址為 192.168.1.1
255.255.255.0
192.168.1.2
配置路由器B的主機名和介面參數
router>enable
router#c onfigure terminal
router(conf)#hostname routerB
routerB(conf)#interface fastethernet 0/0
路由器B0埠為兩路由器的連接埠
routerB(conf-if)#ip address 192.168.2.2 255.255.255.0
routerB(conf-if)#no shutdown
routerB (conf-if)#exit
routerB(conf)# interface fastethernet 0/1
路由器B1埠為與主機的連接埠
routerB(conf-if)#ip address 192.168.3.1 255.255.255.0
主機Bip位址為 192.168.3.2
255.255.255.0
192.168.3.1
配置路由器A的靜態路由表
routerA(conf)#ip router 192.168.3.0 255.255.255.0 192.168.2.2
配置路由器B的靜態路由表
routerA(conf)#ip router 192.168.1.0 255.255.255.0 192.168.2.1
routerArouterB上配置默認路由
routerA(conf)#ip route 0.0.0.0 0.0.0.0 192.168.2.2
routerA(conf)#ip classless
routerB(conf)#ip route 0.0.0.0 0.0.0.0 192.168.2.1
routerB(conf)#ip classless
routerArouterB上配置動態路由(RIP)
routerA(conf)#router rip
routerA(conf)#network 192.168.1.0
routerA(conf)#network 192.168.2.0
routerB(conf)# router rip
routerB(conf)#network 192.168.2.0
routerB(conf)#network 192.168.3.0




=================================================







Switch的基本配置
switch>
用戶模式
1
:進入特權模式 enable
switch> enable
switch#
2
:進入全局配置模式 configure terminal
switch> enable
switch#configure terminal
switch(conf)#
3
:交換機命名 2950為例
switch> enable
switch#configure terminal
switch(conf)#hostname 2950
2950(conf)#
4
:配置使能口令 cisco為例
switch> enable
switch#configure terminal
switch(conf)#hostname 2950
(conf)# enable password cisco
5
:配置使能密碼 enable secret ciscolab cicsolab為例
switch> enable
switch#configure terminal
switch(conf)#hostname 2950
2950(conf)# enable secret ciscolab
6
:設置虛擬局域網vlan 1 interface vlan 1
switch> enable
switch#configure terminal
switch(conf)#hostname 2950
2950(conf)# interface vlan 1
(conf-if)#ip address 192.168.1.1 255.255.255.0
配置交換機埠ip和子網路遮罩
2950(conf-if)#no shut
2950(conf-if)#exit
2950(conf)#ip default-gateway 192.168.1.254
設置閘道位址
7
:進入交換機某一埠 interface fastehernet 0/17 17埠為例
switch> enable
switch#configure terminal
switch(conf)#hostname aptch2950
2950(conf)# interface fastehernet 0/17
2950(conf-if)#
8
:查看命令 show
switch> enable
switch# show version
察看系統中的所有版本資訊
show interface vlan 1
查看交換機有關ip 協定的配置資訊
show running-configure
查看交換機當前起作用的配置資訊
show interface fastethernet 0/1
察看交換機1介面具體配置和統計資訊
show mac-address-table
查看mac地址表
show mac-address-table aging-time
查看mac位址表自動老化時間
9
:交換機恢復出廠默認恢復命令
switch> enable
switch# erase startup-configure
switch# reload

10
:雙工模式設置
switch> enable
switch#configure terminal
2950(conf)#hostname aptch-2950
2950(conf)# interface fastehernet 0/17
17埠為例
2950(conf-if)#duplex full/half/auto
full , half, auto 三個可選項
11
cdp相關命令
switch> enable
switch# show cdp
查看設備的cdp全局配置資訊
show cdp interface fastethernet 0/17
查看17埠的cdp配置資訊
show cdp traffic
查看有關cdp包的統計資訊
show cdp nerghbors
列出與設備相連的cisco設備

創作者介紹
創作者 aircsh 的頭像
aircsh

Aries男的學習筆記

aircsh 發表在 痞客邦 留言(0) 人氣()